Opened 10 years ago

Closed 9 years ago

Last modified 45 years ago

#204 closed Bugs (Fixed)

Quotation marks cause strange insert behavior

Reported by: nobody Owned by: nobody
Priority: 5 Milestone:
Component: PHP Editor Version: v1.0 (example)
Keywords: Cc:

Description

When using PHPEclipse 1.1.1 with Eclipse Version: 3.0.1
Build id: 200409161125 running on Windows XP with Sun
J2SE Version 1.5.0 (build 1.5.0-b64) I experience the
following issue:

When typing PHP code with quotation marks (single or
double) the highlighting engine becomes confused.  The
highlighting is thrown off (i.e. the rest of the code
is highligted as text) and the cursor begins to insert
text on the left hand side as I type.

Example:  I wish to type in:

    $gl_ActionCode = $_POST['glActionCode'];

After entering the closing single quotation mark, the
editor begins to insert backwards so that this is what
appears on the screen:

    $gl_ActionCode = $_POST['glActionCode;]'

The insert worked properly until I closed the quote. 
Then it began the insert sequence backwards.  I have
tried disabling everyting in the preferences for the
workspace, but to no avail.  So long as I have
PHPEclipse loaded, this happens -- but not in ALL
situations.  Some lines insert with quotes (single or
double) without any problem.

I have reviewed the other bugs that mention a problem
with quotation marks, but none appear to have the exact
same set of issues.  Please email me and I will be
happy to provide you with any additional information.

ssokol [at] sokol-associates [d0t] com

Thanks,

Steve

Change History (6)

comment:1 Changed 10 years ago by nobody

Logged In: NO 

Could you please try version 1.1.2
(Re-)start eclipse once with the "-clean" option to be sure
that the plugin.xml cache will be refreshed.

comment:2 Changed 10 years ago by nobody

Logged In: NO 

i am having the same issue with 1.1.2

comment:3 Changed 10 years ago by webpit

Logged In: YES 
user_id=1206166

I too can confirm this as a bug.

It is rather annoying.  I have tried to turn off all
validation, code assist, etc, to no avail.  The only way to
cure the problem is close the file and reopen it.

for example:

i start typing in 

include "config.php";

as soon as i hit the second quote, it backtracks and wants
to put the ; inside the quotes, and starts giving me
assertion errors if i try to delete the ; and move to the
end of the line to put it in.

comment:4 Changed 10 years ago by thoras

Logged In: YES 
user_id=1268557

I have this problem as well in phpeclipse 1.1.3
but we are not alone :
http://www.myeclipseide.com/index.php?name=PNphpBB2&file=viewtopic&t=6304&start=0&postdays=0&postorder=asc&highlight=

I think it is rather an Eclipse issue

If I try to press DEL, then I get this error: "The command
for the key you pressed failed.

comment:5 Changed 9 years ago by bananeweizen

Logged In: YES 
user_id=440739

Can't reproduce this with a recent version. And due to
bracket matching and insertion you shouldn't even run into
the described situation anymore.

comment:6 Changed 9 years ago by bananeweizen

  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.