Opened 12 years ago

Closed 11 years ago

Last modified 45 years ago

#21 closed Bugs (Out of Date)

Save Failed: unexpected character: '\'

Reported by: kevinscarr Owned by: nobody
Priority: 5 Milestone:
Component: None Version: None
Keywords: Cc:

Description

If you have an error in your code.  Let's say something
like:

$strRET .= sprintf(\"this is a test %s", $mystr);

You recieve the Error Message like the above.  If you
then exit the interface, you will not be allowed back
in Eclipse at all.

It is a rather interesting error.  I understand you
should do this bad of coding, but I was doing a search
and replace.  You gotta give me some break.  

Change History (4)

comment:1 Changed 11 years ago by nobody

Logged In: NO 

I couldn't reproduce this error in my current development 
environment.
What do you mean exactly by "exiting the interface"?
Could you look into the eclipe/workspace/.metadata/.log if 
there is an exception trace?

comment:2 Changed 11 years ago by globaster

Logged In: YES 
user_id=732447

Hi there,
well I had the same problem several times. Since I use the
swiss-german character set I use quite a lot of foreign
letters like ü (ü) and others. 

I guess Scott meat closing eclipse with "exit the
interface". I did that too and couldn't restart the whole
program. I found a workaround, so one doesn't have  to
reinstall the IDE:
go into the plugins folder of your (!) installed plugins.
then into the org.eclipse.ui.workbench folder and open
workbench.xml . I figured that all the statements between
<ediotrs> and </editors> are the open editors. I just
deleted all that, and I was able to start eclipse again.
this might help some to get back to work.
nice day
Lukas
ps the exception is thorwn by the phpparser

comment:3 Changed 11 years ago by kevinscarr

Logged In: YES 
user_id=414180

What I mean is that if you exit Eclipse, then try to open it
again, you get the error I mentioned.

I'll try it with the latest to see if this is still a problem.

Thanks

comment:4 Changed 11 years ago by jsurfer

  • Status changed from assigned to closed
Logged In: YES 
user_id=810238

Seems to be fixed in 1.0.8a.
Please resubmit again if necessary.
Note: See TracTickets for help on using tickets.