wiki:General/PHPEclipseFAQ

PHPEclipse FAQ

Here you can find answers to some of the most frequently asked questions about PHPEclipse. If you have a question not answered on this page, you can ask it on the MailingList or in the IrcChannel. See the PHPEclipseSupport page for more options on getting support for PHPEclipse.


  1. PHPEclipse Versions
    1. What is the current release version of PHPEclipse?
    2. How do I find my PHPEclipse version?
    3. Are PHPEclipse Nightlies stable?
    4. How well does PHPEclipse work with Eclipse 3.4 Ganymede?
    5. How do I install the latest PHPEclipse Nightly?
      1. Install PHPEclipse in Eclipse (before 3.4 M6)
      2. Install PHPEclipse in Eclipse (since 3.4 M6)
    6. How will I switch to the Stable build once it's done?
  2. Developing with PHPEclipse
    1. How do I use PHPEclipse with Remote files?
    2. How do I use PHPEclipse and Subversion?
    3. How do I use PHPEclipse with Mylyn?
    4. How do I set the project URL/browser path?
      1. To change it for all projects:
      2. To change it per project:
    5. How do i include external php files in my project?
      1. To change it for all projects:
      2. To Change it per project:
    6. Can I tell the PHP explorer to re-build the file list?
    7. Set system to default open php files in Eclipse
  3. Trouble-shooting
    1. I installed PDT All-in-one and now...?
    2. How do I disable PDT?
      1. Disable PDT in Eclipse (before 3.4 M6)
      2. Disable PDT in Eclipse (since 3.4 M6)
    3. XDebug does not work!
    4. DBG Debugger
      1. DBG does not work!
      2. DBG clienthost option is not working
    5. Okay debugging still does not work!
    6. Does Debugging work with linked folders?
    7. Does debugging work with NFS/SMB shares?
    8. Your docs suck! Debugging still does not work!!!


PHPEclipse Versions

What is the current release version of PHPEclipse?

The current release version of PHPEclipse is 1.1.9 & 1.2.0. If you are using Eclipse 3.2 use 1.1.9 release, if using Eclipse >= 3.3 then use 1.2.0.

How do I find my PHPEclipse version?

Inside Eclipse click Help -> About Eclipse SDK -> Plug-in Details
PHPEclipse will have a provider of "PHPEclipse project team". If you find this in the list, you can also get the version, it should be two columns to the right. If you cannot find "PHPEclipse project team" then PHPEclipse is not installed.

Are PHPEclipse Nightlies stable?

Yes, at the moment PHPEclipse Nightlies are pretty stable. We have several developers using it as well as users. The Nightly is going to be the 1.2.0 release which is not that far out.

How well does PHPEclipse work with Eclipse 3.4 Ganymede?

PHPEclipse 1.2.x(nightly) works well with Eclipse 3.4 Ganymede. There however is one known issue that we are aware of. We have requested more people to work with Ganymede to help find other issues.

How do I install the latest PHPEclipse Nightly?

You can install the latest Nightly using our Update Site. As Eclipse's configuration manager has been recently changed, the procedure depends on the Eclipse version you use:

Install PHPEclipse in Eclipse (before 3.4 M6)

  1. In the Eclipse main menu, choose Help -> Software Updates -> Find and Install.
  2. Then select Search for new features to install -> Next.
  3. Create a new remote site with the name: PHPEclipse Nightly and the URL http://update.phpeclipse.net/update/nightly, click "OK".
  4. Make sure PHPEclipse Nightly is checked, then click "Finish".

After installation, the PHP perspective needs to be activated. To do that, go to Window -> Open Perspective -> Other -> Select PHP -> Ok.

Install PHPEclipse in Eclipse (since 3.4 M6)

  1. In the main menu, choose Help -> Software Updates and switch to the tab "Available Software".
  2. On the bottom of the dialog, make sure "Show only the latest versions of available software" is checked, and "Include items that have already been installed" is unchecked.
  3. Click the "Add site" button to open the "Add site" dialog.
  4. Enter the URL http://update.phpeclipse.net/update/nightly. Click the "OK" button.
  5. Highlight the new entry "update site: http://update.phpeclipse.net/update/nightly" and open it using the little arrow handler left to the checkbox.
  6. The sub-entry "PHP Eclipse Nightly Builds" should appear. Check the appropriate checkbox.
  7. After verifying that no other checkboxes are checked, click the "Install" button.
  8. After the despendencies have been successfully resolved, a confirmation screen is displayed. Click the "Next >" button.
  9. Read the license text and select "I accept the terms of the license agreements". Click the "Finish" button.
  10. Restart Eclipse.

After installation, the PHP perspective needs to be activated. To do that, go to Window -> Open Perspective -> Other -> Select PHP -> Ok.

How will I switch to the Stable build once it's done?

Once the 1.2.0 Stable build for PHPEclipse is released, you will not want to use new Nightly builds anymore. Therefore you can remove the Nightly update site, and replace it by the new Stable release update site. Nightlies after the 1.2.0 Stable build may have brand new features, that make it unstable and introduce strange bugs.

Developing with PHPEclipse

How do I use PHPEclipse with Remote files?

If you work on projects located on a remote server, you can use RSE to connect to these sites. The current PHPEclipse Nightly supports the RSE feature. Also it is recommended that you run Eclipse > 3.3.1.

How do I use PHPEclipse and Subversion?

You can use PHPEclipse with Subversion by installing either Subversive or Subclipse.

How do I use PHPEclipse with Mylyn?

You can install Mylyn, but as of the 1.2.0 release we do not currently interact with its API. You can still benefit from its project filtering and integration with Bugzilla, Trac, and JIRA.

How do I set the project URL/browser path?

There are two methods to set the project URL/browser path:

To change it for all projects:

  • Click Window -> Preferences -> PHPEclipse -> Project Defaults.
  • You can change the localhost and DocumentRoot for all projects, and also the include Paths for all projects.

To change it per project:

  • Right click project -> Properties -> PHP Project Settings.
  • Select Use project settings, and then change your url and DocumentRoot. You can also add Include paths for the project.

How do i include external php files in my project?

If you want to include external files in your project so that the parser will pick them up you have two methods. The files will need to be on the local file system.

To change it for all projects:

  • Click Window -> Preferences -> PHPEclipse -> Project Defautls.
  • Under Include Paths: Click new and enter the path to the php files.

To Change it per project:

  • Right click project -> Properties -> PHP Project Settings.
  • Select Use project settings, and Under Include Paths: click new and add the path to your php files.

Can I tell the PHP explorer to re-build the file list?

Yes. Right click on the top folder and click refresh. This should update the projects files/directories.

Set system to default open php files in Eclipse

This has been asked a few times, and it is currently not possible to do it in a way many people will want. You can set your desktop preferences for your OS to open php files with Eclipse, but for every file you open a new instance of Eclipse will start. This is a know issue with Eclipse and you can view the bugs for it here. The work that has been done on this bug may resolve the issue, only time will tell. So if you really want to do it. Here are the steps for windows.

  1. Open My Computer (double click).
  2. Select Tools -> File Options.
  3. Select File Types tab.
  4. Click new type php into the File Extension box. Then click Ok.
  5. Search the list for PHP Extension. and click 'Change' under Details for 'PHP' extension.
  6. Select the radio button 'Select the program from a list' then Ok.
  7. Click Browse and find your eclipse exe. Then Ok to set it.
  8. Click Apply and close.

Trouble-shooting

I installed PDT All-in-one and now...?

PDT and PHPEclipse are very separate projects. If you want to use PHPEclipse it is recommended that you disable PDT. It is tough to trouble-shoot problems with PDT enabled.

How do I disable PDT?

Eclipse's configuration manager has been recently changed.

Disable PDT in Eclipse (before 3.4 M6)

  1. In the main menu, choose Help -> Software Updates -> Manage Configuration
  2. Look for PDT click it once, then click disable. You will need to restart Eclipse once you have preformed this action.

Disable PDT in Eclipse (since 3.4 M6)

Since Eclipse 3.4 the Help -> Software Updates menu item has been disabled per default. It can be enabled again:

  1. In the main menu, choose Window -> Preferences -> General -> Cababilities
  2. Enable the check box 'Classic Update' (now you can disable plugins as in former Eclipse versions).
  3. In the main menu, choose Help -> Software Updates -> Manage Configuration
  4. Look for PDT click it once, then click disable. You will need to restart Eclipse once you have preformed this action.

Alternatively you can deinstall PDT by the following steps:

  1. In the main menu, choose Help -> Software Updates
  2. On the tab "Installed Software", highlight the entry "PDT Feature"
  3. Click the "Uninstall" button.
  4. After the despendencies have been successfully resolved, a confirmation screen is displayed. Click the "Finish" button.
  5. Optionally, also remove all other plugins that PDT depends on, but not PHPEclipse.
  6. Restart Eclipse.

XDebug does not work!

First thing you need to do is make sure that you did not install the DBG feature as well.
To check that DBG is not installed, go to Help -> Software Updates -> Manage Configuration
Look for DBG, and if it is listed, click on it and then click "Disable". You will need to restart Eclipse once you have preformed this action.

DBG Debugger

DBG does not work!

First thing you need to do is make sure that you did not install the XDebug feature as well.
To check that XDebug is not installed go to Help -> Software Updates -> Manage Configuration
Look for XDebug, and if it is listed, click on it and then click "Disable". You will need to restart Eclipse once you have preformed this action.

DBG clienthost option is not working

You may have set debugger.JIT_host = clienthost and it is not using your client IP Address. This is because DBG uses HTTP_SERVER_VARS to find out the IP address of the calling host. To fix this you need to turn register_long_arrays to On. Search your php.ini file for register_long_arrays and set it to On.

register_long_arrays On

Okay debugging still does not work!

If you have done the above and your debugger still does not work try following our documentation.
For XDebug see XDebug and PHPEclipse wiki page
For DBG see DBG and PHPEclipse wiki page.

Does Debugging work with linked folders?

Yes, XDebug & DBG will work with linked folders. You will need to configure the mapPath for the linked folder. For the debugger that you are using you should be able to find information in there documentation on how this works.

Does debugging work with NFS/SMB shares?

Yes, debug will work with NFS and SMB shares. Just make sure that the paths are in your workspace.

Your docs suck! Debugging still does not work!!!

Well, first calm down and take a few breaths. You will probably want to do one of three things.

  1. Join our PHPEclipse IRC channel and ask for help. Prepare to wait. Depending on the time of day someone might not be in to help you. Give it time tho we do want to help.
  2. Post a message in the Forum about your problem. Again you will need to wait.
  3. Re-read the stinking docs to insure that you have followed them correctly.
Last modified 16 months ago Last modified on 2013-01-06T04:08:41-06:00