wiki:General/PHPEclipseFAQFr

PHPEclipse FAQ (Questions Fréquemment Posées)

Ici vous pouvez trouver des réponses aux questions les plus fréquemment posées au sujet de PHPEclipse. Si vous avez une question sans réponse sur cette page, vous pouvez la poser sur la MailingList ou sur IrcChannel. Regardez la page PHPEclipseSupport pour toutes les possibilités de support de PHPEclipse.


  1. PHPEclipse Versions
    1. Quelle est la version actuelle de PHPEclipse?
    2. Comment puis-je savoir ma version de PHPEclipse?
    3. Est-ce que la version nocture(Nightly) est stable?
    4. Comme je peux installer la version nocture(Nightly)?
    5. Comment vais-je basculer sur la version stable quand elle sera finie ?
  2. Développer avec PHPEclipse
    1. Comment puis-je utiliser PHPEclipse avec des fichiers distants?
    2. Comment puis-je utiliser PHPEclipse et Subversion?
    3. Comment puis-je utiliser PHPEclipse avec Mylyn?
    4. Puis-je demander à l'explorateur PHP de reconstruire la liste des fichiers ?
    5. Comment puis-je configurer l'url et le chemin du projet
      1. Le changer pour tous les projets:
      2. Le changer pour un projet:
  3. Problèmes
    1. J'ai installé PDT tout-en-un et ...?
    2. Comment puis-je désactiver PDT?
    3. XDebug ne fonctionne pas!
    4. DBG ne fonctionne pas!
    5. Ok le débogage ne fonctionne toujours pas!
    6. Es-ce que le débogage fonctionne avec les dossiers liés?
    7. Es-ce que le débogage fonctionne avec les partages NFS/SMB?
    8. Vos docs c'est de la merde! Le débogage ne fonctionne toujours pas!!!


PHPEclipse Versions

Quelle est la version actuelle de PHPEclipse?

La version actuelle de PHPEclipse est 1.1.8. Toutefois il est recommandé d'utiliser la version nocturne(Nightly) depuis que la version 1.2.0 est sortie.

Comment puis-je savoir ma version de PHPEclipse?

Depuis Eclipse cliquez sur Help->About Eclipse SDK -> Plug-in Details
PHPEclipse aura comme provider "PHPEclipse project team". Si vous le trouvez dans la liste vous pourrez obtenir la version, elle devrait être dans la deuxième colone à droite. Si vous ne pouvez pas trouver "PHPEclipse project team" sela signifie que PHPEclipse n'est pas installé.

Est-ce que la version nocture(Nightly) est stable?

Oui la version nocture(Nightly) est stable. Nous avons beaucoup de développeurs qui l'utilisent ainsi que d'utilisateur. La version nocture(Nightly) est appelée à devenir la version 1.2.0 et elle n'en est plus très loin.

Comme je peux installer la version nocture(Nightly)?

Vous pouvez installer la version nocture(Nightly) en utilisant notre site de mise à jour et les instructions suivantes.

  • Lancez Eclipse et cliquer sur Help-> Software Updates -> Find and Install.
  • Ensuite sélectionnez Search for new features to install -> Next.
  • Puis "New Remote Site" Name: PHPEclipse Nightly. L'url doit être http://update.phpeclipse.net/update/nightly et cliqez sur Ok.
  • Assuez vous que PHPEclipse Nightly est choché et cliquez sur Finish.
  • Après l'installation vous devrez activer la perspective, pour se faire faite Window-> Open Perspective ->Other -> Select PHP -> Ok.

Comment vais-je basculer sur la version stable quand elle sera finie ?

Une fois la version stable de PHPEclipse finie, vous pourrez retirer le site de mise à jour nocturne(Nightly), et et configurer le nouveau site de mise à jour pour la version stable. Vous ne voudrez pas utiliser les nouvelles versions noctures après la sortie de la 1.2.0. Puisque les nouvelles versions noctures auront de nouvelles options, elles seront instables et auront de gros problèmes.

Développer avec PHPEclipse

Comment puis-je utiliser PHPEclipse avec des fichiers distants?

Si vous travaillez sur des projets qui sont situé sur un serveur distant, vous pouvez utiliser RSE pour vous connecter à ces sites. La version nocture de PHPEclipse supporte RSE. Mais il est recommandé d'utiliser les version d'Eclipse > 3.3.1.

Comment puis-je utiliser PHPEclipse et Subversion?

Vous pouvez utiliser PHPEclipse avec subversion en installant subversive ou subclipse.

Comment puis-je utiliser PHPEclipse avec Mylyn?

Vous pouvez installer Mylyn mais la version 1.2.0 n'est pas encore lié à cette API. Vous pouvez toutefois bénéficier de ce projet, et l'intégrer avec Bugzilla, Trac et JIRA.

Puis-je demander à l'explorateur PHP de reconstruire la liste des fichiers ?

Oui, clique droit sur le répertoire principal et cliquez sur refresh. Cela devrait mettre à jour la liste des fichiers/dossiers du projet.

Comment puis-je configurer l'url et le chemin du projet

Il y a deux méthodes pour configurer l'url et le chemin du projet.

Le changer pour tous les projets:

Cliquez sur Window->Preferences->PHPEclipse->Project Defaults. Vous pouvez changer le localhost et DocumentRoot pour tous les projets, et aussi le chemin des includes pour tous les projets.

Le changer pour un projet:

Clique droits dur le dossier principale du projet->Properties->PHP Project Settings. Selectionnez Use project settings, et ensuite changer l'url et le DocumentRoot. vous pouvez aussi changer le chemin des includes pour le projet.

Problèmes

J'ai installé PDT tout-en-un et ...?

PDT et PHPEclipse sont deux projets vraiment séparés. Si vous voulez utiliser PHPEclipse il est recommandé de désactiver PDT. Il est difficile de réparer les problèmes avec PDT actif.

Comment puis-je désactiver PDT?

Pour désactiver PDT dans Eclipse faites ceci
Help->Software Updates -> Manage Configuration
Regardez pour PDT et cliquez une fois dessus, ensuite cliquez sur disable. Vous devrez redémarrer Eclipse après avoir effectué cette action.

XDebug ne fonctionne pas!

La première chose que vous devez faire et de vous assurer de ne pas avoir aussi installé DBG avec XDebug. Pour vérifier que DBG n'est pas installé faites ceci:
Help->Software Updates -> Manage Configuration
Regardez après DBG et si il est listé cliquez dessus et désactivez le. Vous devrez redémarrer Eclipse après avoir effectué cette action.

DBG ne fonctionne pas!

La première chose que vous devez faire et de vous assuer de ne pas avoir aussi installé XDebug. Pour vérifier que XDebug n'est pas installé faites ceci:
Help->Software Updates -> Manage Configuration
Regardez après XDebug et si il est listé cliquez dessus et désactivez le. Vous devrez redémarrer Eclipse après avoir effectué cette action. (j'ai l'impression de me répéter)

Ok le débogage ne fonctionne toujours pas!

Si vous avez déjà vérifié ce qu'il y a au dessus et que le débuggeur ne fonctionne toujours pas essayez de suivre notre documentation.
Pour XDebug regardez XDebug and PHPEclipse wiki page
Pour DBG regardez DBG and PHPEclipse? wiki page

Es-ce que le débogage fonctionne avec les dossiers liés?

Oui XDebug & DBG fonctionne avec les dossiers liés. Vous allez devoir configurer le mapPath pour les dossiers liés. Selon le débogger que vous utilisez vous devriez trouver les informations dans leur documentation respectives.

Es-ce que le débogage fonctionne avec les partages NFS/SMB?

Oui le débogage fonctionne avec les partages NFS et SMB. Assurez vous simplement que les chemins sont dans votre workspace.

Vos docs c'est de la merde! Le débogage ne fonctionne toujours pas!!!

Bon, premièrement restez calme et respirez un coup. Vous devriez faire 1 ou 3 choses.

  1. Nous rejoindre sur le canal PHPEclipse IRC et demander de l'aide. Préparez vous à attendre. Selon le moment de la journée certain d'entre nous ne seront pas là pour vous aider.
  2. Postez un message dans Forum au sujet de votre probleme. Pareil vous devrez patienter.
  3. Relire la documentation pour vous assurez que vous avez suivit les instructions correctement.
Last modified 4 years ago Last modified on Jan 6, 2013 4:09:42 AM